electronic_cigarette
https://ift.tt/eA8V8J
Smok Nord 2 – constant gurgling and small spits no matter the coil https://ift.tt/35vs5c0

I'm not sure what i'm doing wrong. When i first received the Nord 2, it came with a 0.8 coil in the standard pod(can't remember if it was mesh or regular). It worked amazingly to start with. I filled the pod slowly, as if i was pouring a pint not going over the fill line. I let it sit and soak(standing upright) for 15 minutes. There was really no issues to start besides a small leak at the bottom pin, but it stopped pretty quickly. I was using the 0.8 at 15 wattage. No issues.

A week since purchase and use, i decided to try a different coil, 0.6 mesh coil. Done exactly the same routine. Slow fill and let it sit. Upped the wattage to 22. This was where i started to google about flooding. It was constantly gurgling and doing small spits. I was however, using a different brand of juice.(still 50/50 as it was with the 0.8 regular, just different brand). I blowed into the pod piece to clear any liquid, wiped it away from the bottom(it appears to leak everytime it gurgles and spits, but the leak stops eventually). Let it sit for a bit and tried again. Still gurgling and puking up little smoke balls.

I inserted another 0.6 mesh to see if the coil was a faulty, same shit happened.

Starting to get irritated, i bought 1.4 regular coils. Done the steps as i did to start. Let it sat. Adjusted wattage to 10w. I was using the same brand of juice i tried with the 0.6 mesh coil. Gurgling and fucking spitting. Seems like i'm doing something wrong but i don't understand what. Tried another 1.4 regular incase it was a faulty, same shit again.

Would different brands of liquid effect this?

I'm trying the first original brand of juice i used(with the 0.8 regular) today on a 1.4 regular coil. If this fails, i'm not sure what else i can do lol.

All juices i used are 50/50. It worked perfectly fine with the 0.8 coil that came with the nord 2, but 0.6 mesh and 1.4 regular with the preferred wattage are just gurgling and spitting small. I've also tried holding the power button down to try vape it off without burning but it still comes back to the gurgling antics regardless.

Any tips? Should i bin it if all else fails and look for a different pod vape? Or a different style of vape entirely?

I’m not sure what i’m doing wrong. When i first received the Nord 2, it came with a 0.8 coil in the standard pod(can’t remember if it was mesh or regular). It worked amazingly to start with. I filled the pod slowly, as if i was pouring a pint not going over the fill line. I let it sit and soak(standing upright) for 15 minutes. There was really no issues to start besides a small leak at the bottom pin, but it stopped pretty quickly. I was using the 0.8 at 15 wattage. No issues.A week since purchase and use, i decided to try a different coil, 0.6 mesh coil. Done exactly the same routine. Slow fill and let it sit. Upped the wattage to 22. This was where i started to google about flooding. It was constantly gurgling and doing small spits. I was however, using a different brand of juice.(still 50/50 as it was with the 0.8 regular, just different brand). I blowed into the pod piece to clear any liquid, wiped it away from the bottom(it appears to leak everytime it gurgles and spits, but the leak stops eventually). Let it sit for a bit and tried again. Still gurgling and puking up little smoke balls.I inserted another 0.6 mesh to see if the coil was a faulty, same shit happened.Starting to get irritated, i bought 1.4 regular coils. Done the steps as i did to start. Let it sat. Adjusted wattage to 10w. I was using the same brand of juice i tried with the 0.6 mesh coil. Gurgling and fucking spitting. Seems like i’m doing something wrong but i don’t understand what. Tried another 1.4 regular incase it was a faulty, same shit again.Would different brands of liquid effect this?I’m trying the first original brand of juice i used(with the 0.8 regular) today on a 1.4 regular coil. If this fails, i’m not sure what else i can do lol.All juices i used are 50/50. It worked perfectly fine with the 0.8 coil that came with the nord 2, but 0.6 mesh and 1.4 regular with the preferred wattage are just gurgling and spitting small. I’ve also tried holding the power button down to try vape it off without burning but it still comes back to the gurgling antics regardless.Any tips? Should i bin it if all else fails and look for a different pod vape? Or a different style of vape entirely?

Submitted September 12, 2020 at 04:11PM by Slowhigh
via reddit https://ift.tt/2FhwWD0}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s