electronic_cigarette
https://ift.tt/eA8V8J
Aegis legend not detecting battery https://ift.tt/2FbaxXU

I bought an aegis legend 200w just over a month ago and I’ve loved it until about a week ago. To start with one of my battery’s in the display was reading lower than the other, a day later it was showing the battery as empty. All I did to fix this was take the battery’s out and put them back in, and no issues. Then it started happening more every time I went to pick the mod up the battery is showing as empty. I bought new battery’s, cleaned the connectors and made sure it’s has the latest firmware.

The website I ordered from only have a month guarantee and I ordered it over a month ago so they’re not being very helpful. Is there a way to fix this or do I need to get a replacement?

I bought an aegis legend 200w just over a month ago and I’ve loved it until about a week ago. To start with one of my battery’s in the display was reading lower than the other, a day later it was showing the battery as empty. All I did to fix this was take the battery’s out and put them back in, and no issues. Then it started happening more every time I went to pick the mod up the battery is showing as empty. I bought new battery’s, cleaned the connectors and made sure it’s has the latest firmware.The website I ordered from only have a month guarantee and I ordered it over a month ago so they’re not being very helpful. Is there a way to fix this or do I need to get a replacement?

Submitted October 06, 2020 at 02:28PM by Drahcir1
via reddit https://ift.tt/34AjDG6}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s