Vaping101
https://ift.tt/eA8V8J
My Recurve Dual is doing some weird shit with my coils. https://ift.tt/36KQVVL

So, when glowing my coils, one side heats up MUCH faster than the other and it seems like it takes a very long time for them to glow at the 15-25w. Now if I take out the coil that was heating faster, the remaining coil glows normally.

BUT NOW that side isn't even glowing when I have both in. So I take out the coil that is glowing and leave the one that isn't.

AND IT GLOWS JUST FINE.
I'm seriously confused. HALP.
Btw, I am new to rebuildables but I'm worried something is fucked up in my deck because sometimes when I'm installed new coils and I'm trying to get them into the post holes I'll see tiny sparks when the coil touches the deck..

So, when glowing my coils, one side heats up MUCH faster than the other and it seems like it takes a very long time for them to glow at the 15-25w. Now if I take out the coil that was heating faster, the remaining coil glows normally.BUT NOW that side isn’t even glowing when I have both in. So I take out the coil that is glowing and leave the one that isn’t.AND IT GLOWS JUST FINE.I’m seriously confused. HALP.Btw, I am new to rebuildables but I’m worried something is fucked up in my deck because sometimes when I’m installed new coils and I’m trying to get them into the post holes I’ll see tiny sparks when the coil touches the deck..

Submitted October 09, 2020 at 01:25AM by PoweredbyDespair
via reddit https://ift.tt/3lsOE5P}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s