electronic_cigarette
https://ift.tt/eA8V8J
Lost Vape Gemini Hybird https://ift.tt/3doxPWG

Just bought the title vape a week ago and im already having issues. I went with the external battery mod this time for obvious reasons but now it seems like its backfiring on me. So i use 18650 batteries (only one at a time since its single battery operated) with 2500mAh ratings. After maybe 20-30 drags on a brand new, fully charged battery, my vape says "low battery". Even the battery icon on the vape itself has it almost fully charged and when i place the "low" battery on the chargfer its fully charged. Any help with this?

Just bought the title vape a week ago and im already having issues. I went with the external battery mod this time for obvious reasons but now it seems like its backfiring on me. So i use 18650 batteries (only one at a time since its single battery operated) with 2500mAh ratings. After maybe 20-30 drags on a brand new, fully charged battery, my vape says “low battery”. Even the battery icon on the vape itself has it almost fully charged and when i place the “low” battery on the chargfer its fully charged. Any help with this?

Submitted October 13, 2020 at 08:21PM by __MP3__
via reddit https://ift.tt/310L0II}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s