DIY_eJuice
https://ift.tt/eA8V8J
I think I got 3 straight harsh shipments of nic https://ift.tt/2HiOoHz

I've been diy-ing for a long time. I've used the same recipe for years. My go to vendor was carolina extract for a while. I've gotten harsh bottles before but they've always replaced them. This time I had gotten two harsh bottles in a row. The first one they sent was harsh and replaced it with another one that was less harsh but still unusable. After contacting them he said that probably has to do with the USPS. They also said if I order it again they would ship it and via FedEx or UPS. But to do that I would have to buy another bottle. figuring it would be the same outcome I tried ordering from liquid nicotine wholesalers. This bottle too seems to be harsh. Both bottles from Carolina the liquid is brown and smelled of tobacco and was quite musty. The bottle had gotten from lnw was clear and didn't really have a smell but was harsh. Am I going crazy? I've never had this problem before. Carolina wanted to blame it on me. I'm starting to think I could be doing something wrong now but I've been using the same recipe for forever and a day. Has anyone else ever had this issue?

I’ve been diy-ing for a long time. I’ve used the same recipe for years. My go to vendor was carolina extract for a while. I’ve gotten harsh bottles before but they’ve always replaced them. This time I had gotten two harsh bottles in a row. The first one they sent was harsh and replaced it with another one that was less harsh but still unusable. After contacting them he said that probably has to do with the USPS. They also said if I order it again they would ship it and via FedEx or UPS. But to do that I would have to buy another bottle. figuring it would be the same outcome I tried ordering from liquid nicotine wholesalers. This bottle too seems to be harsh. Both bottles from Carolina the liquid is brown and smelled of tobacco and was quite musty. The bottle had gotten from lnw was clear and didn’t really have a smell but was harsh. Am I going crazy? I’ve never had this problem before. Carolina wanted to blame it on me. I’m starting to think I could be doing something wrong now but I’ve been using the same recipe for forever and a day. Has anyone else ever had this issue?

Submitted October 18, 2020 at 06:54PM by NameThatWasntTaken
via reddit https://ift.tt/357eGoM}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s