aussievapers
https://ift.tt/eA8V8J
Paranormal 250c Auto Firing with Blotto / Mini Blotto https://ift.tt/35cyHu9

My Paranormal 250c is Auto firing like crazy whenever I screw on either my Blotto or Mini Blotto. Has anyone experienced similar? I've found post all over the internet but no resolutions, except to send it back, not sue if I send it back to the manufacturer or the vendor, I have e-mailed both. I'm pretty sure they don't make these any more?

This mod is 2 months old, literally hardly used. Never dropped. Had never had juice leak on it (to my knowledge). Brand new batts were installed at the time. Literally "Babied" this mod.

Symptoms: Screwing in Blotto or Mini Blotto makes the mod Auto fire like I'm holding the button down. Does not seem to happen when using a Bonza, Falcon 2 or nexMesh on my Paranormal. It's only just started happening, with only what seems to be Blottos.

Attempted Resolutions: Placed Blottos on Odin Mini 75c – Didn't fire. Placed Blottos on Horizon Falcon Stick – Didn't fire. I can put the Blottos onto my Odin 250c for trouble shooting but don't see a point at this stage.

Reset it all to default, it was anyway, checked for updates etc. Blew out battery area and buttons with air in a can – Still fired. Tried a set of older batteries in Paranormal – Still fired. Cry and yell at it – Still fired. E-mailed the vendor and Evolv – Still fired.

Any idea why one type of tank would do this to my Paranormal?

My Paranormal 250c is Auto firing like crazy whenever I screw on either my Blotto or Mini Blotto. Has anyone experienced similar? I’ve found post all over the internet but no resolutions, except to send it back, not sue if I send it back to the manufacturer or the vendor, I have e-mailed both. I’m pretty sure they don’t make these any more?This mod is 2 months old, literally hardly used. Never dropped. Had never had juice leak on it (to my knowledge). Brand new batts were installed at the time. Literally “Babied” this mod.Symptoms: Screwing in Blotto or Mini Blotto makes the mod Auto fire like I’m holding the button down. Does not seem to happen when using a Bonza, Falcon 2 or nexMesh on my Paranormal. It’s only just started happening, with only what seems to be Blottos.Attempted Resolutions: Placed Blottos on Odin Mini 75c – Didn’t fire. Placed Blottos on Horizon Falcon Stick – Didn’t fire. I can put the Blottos onto my Odin 250c for trouble shooting but don’t see a point at this stage.Reset it all to default, it was anyway, checked for updates etc. Blew out battery area and buttons with air in a can – Still fired. Tried a set of older batteries in Paranormal – Still fired. Cry and yell at it – Still fired. E-mailed the vendor and Evolv – Still fired.Any idea why one type of tank would do this to my Paranormal?

Submitted October 18, 2020 at 01:15AM by Vapour3350
via reddit https://ift.tt/35dgVqF}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s