electronic_cigarette
https://ift.tt/eA8V8J
Odin mini DNA 75c batted issue https://ift.tt/3n0lI5P

I have 4 21700 batteries. 2 of them are wrapped black and 2 of them blue, but they aren't paired because I only have single battery 21700 mods.

Tonight my odin mini needed a battery change so I took out the black battery that was in it out and I put in one of the blue batteries. I instantly noticed a rattle after closing it up and then the mod wouldn't turn on. I decided to try the other battery on my charger which was also a blue one and got the same exact result. The other black battery was in another mod so I took it out and put it in the odin and I had no issues with it. There was no rattle and the mod turned on without issue. Feeling somewhat perplexed I put the blue battery in the mod I took the black battery out of wondering if something was wrong with it but it worked perfectly in that mod.

I am confused by this. I have 3 21700 mods. The Topside light, the Pulse v2, and the Odin mini. I have used every one of these batteries in every one of those mods for months with no issue. Well, I had an issue with the odin previously but it was due to the screws on the top of the mod coming loose so it wasn't making a connection with the battery. I checked the screws earlier just to make sure and they were tight so I know its not that.

Has anyone experienced this with their odin mini? Or even a different mod? What could cause this? Any thoughts or ideas would be extremely welcome!

I have 4 21700 batteries. 2 of them are wrapped black and 2 of them blue, but they aren’t paired because I only have single battery 21700 mods.Tonight my odin mini needed a battery change so I took out the black battery that was in it out and I put in one of the blue batteries. I instantly noticed a rattle after closing it up and then the mod wouldn’t turn on. I decided to try the other battery on my charger which was also a blue one and got the same exact result. The other black battery was in another mod so I took it out and put it in the odin and I had no issues with it. There was no rattle and the mod turned on without issue. Feeling somewhat perplexed I put the blue battery in the mod I took the black battery out of wondering if something was wrong with it but it worked perfectly in that mod.I am confused by this. I have 3 21700 mods. The Topside light, the Pulse v2, and the Odin mini. I have used every one of these batteries in every one of those mods for months with no issue. Well, I had an issue with the odin previously but it was due to the screws on the top of the mod coming loose so it wasn’t making a connection with the battery. I checked the screws earlier just to make sure and they were tight so I know its not that.Has anyone experienced this with their odin mini? Or even a different mod? What could cause this? Any thoughts or ideas would be extremely welcome!

Submitted November 06, 2020 at 04:57PM by DasMenace
via reddit https://ift.tt/3laI5oH}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s